W oczekiwaniu na 3.5: aktualizacja bibliotek

Zewnętrzne biblioteki, z których korzysta WordPress zostały zaktualizowane odpowiednio do wersji:

  • TinyMCE 3.5.6
  • jQuery 1.8.0
  • jQuery UI 1.8.23
  • jQuery Color 2.1.0
  • Jcrop 0.9.10
  • Backbone.js 0.9.2
  • Underscore.js 1.3.3

Aktualizacja została dokonana w trunku, czyli dotyczy każdego następnego, dużego wydania.

Jak zwykle przy tego typu aktualizacjach, wszyscy developerzy, których wtyczki lub motywy korzystają z wymienionych bibliotek, proszeni są o przetestowania działania swoich programów.

Większą zmianą jest usunięcie z core’a skryptów Prototype i script.aculo.us. Wymienione skrypty są nadal zarejestrowane i można z nich skorzystać, ale serwowane już będą tylko z ajax.googleapis.com. Zachowanie rejestracji skryptów zostawiono jako wsteczną zgodność, choć ich użycie jest na tyle znikome, że zdecydowano się nie utrzymywać ich więcej w core.

zobacz oryginalny wpis
External Libraries in 3.5


Opublikowano

in

by

Komentarze

2 odpowiedzi na „W oczekiwaniu na 3.5: aktualizacja bibliotek”

  1. Awatar konradk - tradematik.pl

    warto uwaznie sledzic zmiany odnosnie jQuery. co prawda aktualizacja do 1.8 to jeszcze nic wielkiego, ale kiedy wordpress zdecyduje sie zaktualizowac do 2.0 (ktorego jeszcze nie ma) bedzie to oznaczalo, ze definitywnie porzuci wsparcie dla IE 6 :) jquery2 nie bedzie juz wspierac tej wersji przegladarki od MS

    http://blog.jquery.com/2012/06/28/jquery-core-version-1-9-and-beyond/

    1. Awatar Marcin Pietrzak

      Na razie planują wydać z 1.9 lub 1.8.1.

Jeżeli chcesz skomentować, napisz mail na adres marcin w domenie strony na której jesteś. Dodam twoj komentarz.